EGEsoll - сборник решений задач из ЕГЭ

Задача 3 - две кучи

Задание 19

Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежат две кучи камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может убрать из одной из куч один камень или уменьшить количество камней в куче в два раза (если количество камней в куче нечётно, остаётся на 1 камень меньше, чем убирается). Например, пусть в одной куче 6, а в другой 9 камней; такую позицию мы будем обозначать (6, 9). За один ход из позиции (6, 9) можно получить любую из четырёх позиций: (5, 9), (3, 9), (6, 8), (6, 4).

Игра завершается в тот момент, когда суммарное количество камней в кучах становится не более 20. Победителем считается игрок, сделавший последний ход, то есть первым получивший позицию, в которой в кучах будет 20 или меньше камней.

В начальный момент в первой куче было 10 камней, во второй куче — S камней, S > 10.

Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника. Описать стратегию игрока — значит, описать, какой ход он должен сделать в любой ситуации, которая ему может встретиться при различной игре противника. В описание выигрышной стратегии не следует включать ходы играющего по ней игрока, которые не являются для него безусловно выигрышными, то есть не гарантирующие выигрыш независимо от игры противника.

Известно, что Ваня выиграл своим первым ходом после неудачного первого хода Пети. Укажите максимальное значение S, когда такая ситуация возможна.

Задание 20

Найдите пять таких значений S, при которых у Пети есть выигрышная стратегия, причём одновременно выполняются два условия:

— Петя не может выиграть за один ход;

— Петя может выиграть своим вторым ходом независимо от того, как будет ходить Ваня.

Найденные значения запишите в ответе в порядке возрастания без разделительных знаков.

Задание 21

Найдите максимальное значение S, при котором одновременно выполняются два условия:

— у Вани есть выигрышная стратегия, позволяющая ему выиграть первым или вторым ходом при любой игре Пети;

— у Вани нет стратегии, которая позволит ему гарантированно выиграть первым ходом.

Добавлено: 05.04.26 15:18

Перейти к решению

Решение

Решение на Python:

def f(m, s1, s2):
    if s1 + s2 <= 20:
        return m % 2 == 0
    if m == 0:
        return 0
    h = [
        f(m - 1, s1 - 1, s2),
        f(m - 1, s1, s2 - 1),
        f(m - 1, s1 // 2, s2),
        f(m - 1, s1, s2 // 2),
    ]
    # Для решения 19 необходимо поменять all() на any()
    return any(h) if m % 2 != 0 else all(h)


print("19: ", [s for s in range(10, 10_000) if f(2, 10, s)])  # 43
print(
    "20: ", [s for s in range(10, 10_000) if not f(1, 10, s) and f(3, 10, s)]
)  # 23 24 32 44 45
print(
    "21: ",
    [s for s in range(10, 10_000) if not f(2, 10, s) and (f(2, 10, s) or f(4, 10, s))],
)  # 25

19: 43

20: 2324324445

21: 25

Автор - rubygem17

Объяснение

None

Назад