EGEsoll - сборник решений задач из ЕГЭ

Задача 2 - две кучи

Задание 19

Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежат две кучи камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в одну из куч один камень или увеличить количество камней в куче в четыре раза. Например, пусть в одной куче 6 камней, а в другой 9 камней; такую позицию мы будем обозначать (6, 9). За один ход из позиции (6, 9) можно получить любую из четырёх позиций: (7, 9), (24, 9), (6, 10), (6, 36). Чтобы делать ходы, у каждого игрока есть неограниченное количество камней.

Игра завершается в тот момент, когда суммарное количество камней в кучах становится не менее 82. Победителем считается игрок, сделавший последний ход, то есть первым получивший позицию, в которой в кучах будет 82 или больше камней.

В начальный момент в первой куче было 4 камня, во второй куче — S камней, 1 ≤ S ≤ 77.

Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника. Описать стратегию игрока — значит, описать, какой ход он должен сделать в любой ситуации, которая ему может встретиться при различной игре противника. В описание выигрышной стратегии не следует включать ходы играющего по ней игрока, которые не являются для него безусловно выигрышными, то есть не гарантируют выигрыш независимо от игры противника.

Известно, что Ваня выиграл своим первым ходом после неудачного первого хода Пети. Укажите минимальное значение S, когда такая ситуация возможна.

Задание 20

Найдите два таких значения S, при которых у Пети есть выигрышная стратегия, причём одновременно выполняются два условия:

— Петя не может выиграть за один ход;

— Петя может выиграть своим вторым ходом независимо от того, как будет ходить Ваня.

Найденные значения запишите в ответе в порядке возрастания без разделительных знаков.

Задание 21

Найдите минимальное значение S, при котором одновременно выполняются два условия:

— у Вани есть выигрышная стратегия, позволяющая ему выиграть первым или вторым ходом при любой игре Пети;

— у Вани нет стратегии, которая позволит ему гарантированно выиграть первым ходом.

Добавлено: 29.03.26 11:59

Перейти к решению

Решение

Приведём решение на Python:

def f(m, s1, s2):
    if s1 + s2 >= 82:
        return m % 2 == 0
    if m == 0:
        return 0
    h = [
        f(m - 1, s1 + 1, s2),
        f(m - 1, s1, s2 + 1),
        f(m - 1, s1 * 4, s2),
        f(m - 1, s1, s2 * 4),
    ]
    # Для решения 19 необходимо поменять all() на any()
    return any(h) if m % 2 != 0 else all(h)


print("19: ", [s for s in range(1, 78) if f(2, 4, s)])  # 5
print("20: ", [s for s in range(1, 78) if not f(1, 4, s) and f(3, 4, s)])  # 16 19
print(
    "21: ", [s for s in range(1, 78) if not f(2, 4, s) and (f(2, 4, s) or f(4, 4, s))]
)  # 18

Автор - rubygem17

Объяснение

None

Назад