EGEsoll - сборник решений задач из ЕГЭ

Задача 1 - две кучи

19 задание

Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежат две кучи камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в одну из куч (по своему выбору) один камень или увеличить количество камней в куче в два раза. Например, пусть в одной куче 10 камней, а в другой 5 камней; такую позицию в игре будем обозначать (10, 5). Тогда за один ход можно получить любую из четырёх позиций: (11, 5), (20, 5), (10, 6), (10, 10). Для того чтобы делать ходы, у каждого игрока есть неограниченное количество камней.

Игра завершается в тот момент, когда суммарное количество камней в кучах становится не менее 77. Победителем считается игрок, сделавший последний ход, то есть первым получивший такую позицию, при которой в кучах будет 77 или больше камней.

В начальный момент в первой куче было семь камней, во второй куче — S камней; 1 ≤ S ≤ 69.

Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника. Описать стратегию игрока — значит, описать, какой ход он должен сделать в любой ситуации, которая ему может встретиться при различной игре противника. В описание выигрышной стратегии не следует включать ходы играющего по этой стратегии игрока, не являющиеся для него безусловно выигрышными, то есть не являющиеся выигрышными независимо от игры противника.

Известно, что Ваня выиграл своим первым ходом после неудачного первого хода Пети. Укажите минимальное значение S, когда такая ситуация возможна.

20 задание

Найдите два таких значения S, при которых у Пети есть выигрышная стратегия, причём одновременно выполняются два условия:

- Петя не может выиграть за один ход;

- Петя может выиграть своим вторым ходом независимо от того, как будет ходить Ваня.

Найденные значения запишите в ответе в порядке возрастания без разделительных знаков.

21 задание

Найдите минимальное значение S, при котором одновременно выполняются два условия:

- у Вани есть выигрышная стратегия, позволяющая ему выиграть первым или вторым ходом при любой игре Пети;

- у Вани нет стратегии, которая позволит ему гарантированно выиграть первым ходом.

Добавлено: 29.03.26 11:59

Перейти к решению

Решение

Приведём решние заданий на Python:

def f(m, s1, s2):
    if s1 + s2 >= 77:
        return m % 2 == 0
    if m == 0:
        return 0
    h = [
        f(m - 1, s1 + 1, s2),
        f(m - 1, s1, s2 + 1),
        f(m - 1, s1 * 2, s2),
        f(m - 1, s1, s2 * 2),
    ]
    # Для решения 19 номера, необходимо поменять all(h) на any(h)
    return any(h) if m % 2 != 0 else all(h)


print("n19: ", [s for s in range(1, 70) if f(2, 7, s)])  # 18
print("n20: ", [s for s in range(1, 70) if not f(1, 7, s) and f(3, 7, s)])  # 31 34
print(
    "n21: ", [s for s in range(1, 70) if not f(2, 7, s) and (f(2, 7, s) or f(4, 7, s))]
)  # 30, 33

Ответ 19: 18

Ответ 20: 31 34

Ответ 21: 30

Автор - rubygem17

Объяснение

None

Назад