EGEsoll - сборник решений задач из ЕГЭ

Задача 9

Файл содержит последовательность неотрицательных целых чисел, не превышающих 10 000. Назовём тройкой три идущих подряд элемента последовательности. Определите количество троек чисел таких, которые могут являться сторонами прямоугольного треугольника. В ответе запишите два числа: сначала количество найденных троек, а затем  — максимальную сумму элементов таких троек. Если таких троек не найдётся  — следует вывести 0 0.

Download File 1

Добавлено: 17.05.26 09:13

Перейти к решению

Решение

Решение на Python:

a = [int(l) for l in open("embed.txt")]

cnt = 0
m = 0
for i in range(len(a)-2):
    t = sorted([a[i], a[i+1], a[i+2]])
    if t[0]**2 + t[1]**2 == t[2]**2:
        cnt += 1
        m = max(m, sum(t))
print(cnt, m) # 0 0

Ответ: 0 0

Автор - rubygem17

Объяснение

None

Назад