EGEsoll - сборник решений задач из ЕГЭ

Задача 8

Файл содержит последовательность неотрицательных целых чисел, не превышающих 10 000. Назовём тройкой три идущих подряд элемента последовательности. Определите количество троек чисел таких, которые могут являться сторонами остроугольного треугольника. В ответе запишите два числа: сначала количество найденных троек, а затем  — максимальную сумму элементов таких троек. Если таких троек не найдётся  — следует вывести 0 0.

Download File 1

Добавлено: 10.05.26 17:00

Перейти к решению

Решение

Решение на Python:

a = [int(l) for l in open("embed.txt")]
k = 0
maxs = 0
for i in range(len(a)-2):
    t = sorted([a[i], a[i+1], a[i+2]])
    if t[2]**2 < (t[0]**2 + t[1]**2):
        k +=1
        if sum(t) > maxs:
            maxs = sum(t)
print(k, maxs) # 1175 29451

Ответ: 1175 29451

Автор - rubygem17

Объяснение

None

Назад