EGEsoll - сборник решений задач из ЕГЭ

Задача 7

В файле содержится последовательность из 10 000 целых положительных чисел. Каждое число не превышает 10 000. Определите и запишите в ответе сначала количество пар элементов последовательности, для которых произведение элементов кратно 26, затем максимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два различных элемента последовательности. Порядок элементов в паре не важен.

Download File 1

Добавлено: 08.05.26 13:13

Перейти к решению

Решение

Решение на Python:

f = open("embed.txt")
a = [int(line) for line in f.readlines()]

cnt = 0
ms = -1
for i in range(len(a)-1):
    for j in range(i+1, len(a)):
        if a[i] * a[j] % 26 == 0:
            cnt += 1
            if a[i] + a[j] > ms:
                ms = a[i] + a[j]
print(cnt, ms) # 5678937 19984

Ответ: 5678937 19984

Автор - rubygem17

Объяснение

None

Назад