EGEsoll - сборник решений задач из ЕГЭ

Задача 6

Файл содержит последовательность неотрицательных целых чисел, не превышающих 10 000. Назовём парой два идущих подряд элемента последовательности. Определите количество пар, в которых хотя бы один из двух элементов делится на 3, а их сумма делится на 5. В ответе запишите два числа: сначала количество найденных пар, а затем  — максимальную сумму элементов таких пар.

Download File 1

Добавлено: 24.04.26 18:52

Перейти к решению

Решение

Решение на Python:

f = open("embed.txt")
a = [int(line) for line in f.readlines()]

cnt = 0
mxs = 0
for i in range(len(a) - 1):
    if (a[i] % 3 == 0 or a[i + 1] % 3 == 0) and (a[i] + a[i + 1]) % 5 == 0:
        cnt += 1
        if a[i] + a[i + 1] > mxs:
            mxs = a[i] + a[i + 1]
print(cnt, mxs)  # 635 19730

Ответ: 635 19730

Автор - rubygem17

Объяснение

None

Назад