EGEsoll - сборник решений задач из ЕГЭ

Задача 5 досрок

В файле содержится последовательность натуральных чисел. Её элементы могут принимать целые значения от 1 до 100 000 включительно. Определите количество пар элементов последовательности, в которых хотя бы одно число кратно минимальному элементу последовательности, кратному 23. В ответе запишите количество найденных пар, затем максимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента последовательности.

Досрочный вариант 2026 - КЕГЭ

Download File 1

Добавлено: 17.04.26 21:08

Перейти к решению

Решение

Решение на Python:

f = open("embed.txt")
a = [int(line) for line in f.readlines()]
min23 = min([el for el in a if el % 23 == 0])

k = 0
mxs = 0
for i in range(len(a) - 1):
    if a[i] % min23 == 0 or a[i + 1] % min23 == 0:
        k += 1
        if a[i] + a[i + 1] > mxs:
            mxs = a[i] + a[i + 1]
print(k, mxs)  # 113 168437

Ответ: 113 168437

Автор - rubygem17

Объяснение

None

Назад