EGEsoll - сборник решений задач из ЕГЭ

Задача 4

В файле содержится последовательность из 10000 целых положительных чисел. Каждое число не превышает 10000. Определите и запишите в ответе сначала количество пар элементов последовательности, для которых произведение элементов делится без остатка на 10, затем максимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два различных элемента последовательности. Порядок элементов в паре не важен.

Download File 1

Добавлено: 10.04.26 19:30

Перейти к решению

Решение

Ответ: 13510315 19999

Решение на Python:

f = open("embed.txt")
a = [int(line) for line in f.readlines()]
k = 0
mxs = 0
for i in range(len(a) - 1):
    for j in range(i + 1, len(a)):
        if a[i] * a[j] % 10 == 0:
            k += 1
            if a[i] + a[j] > mxs:
                mxs = a[i] + a[j]
print(k, mxs)  # 13510315 19999

Автор - rubygem17

Объяснение

None

Назад