EGEsoll - сборник решений задач из ЕГЭ

Задача 3

В файле содержится последовательность целых чисел. Элементы последовательности могут принимать целые значения от −10000 до 10000 включительно. Определите количество пар последовательности, в которых только одно число оканчивается на 3, а сумма квадратов элементов пары не меньше квадрата максимального элемента последовательности, оканчивающегося на 3. В ответе запишите два числа: сначала количество найденных пар, затем максимальную из сумм квадратов элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента последовательности.

Download File 1

Добавлено: 05.04.26 15:18

Перейти к решению

Решение

Решение на Python:

f = open("embed.txt")
a = [int(line) for line in f.readlines()]
mu = max([el for el in a if str(el)[-1] == "3"])
cnt = 0
mx = 0
for i in range(len(a) - 1):
    if (
        str(a[i])[-1] == "3"
        and str(a[i + 1])[-1] != "3"
        and (a[i] ** 2 + a[i + 1] ** 2) >= mu**2
    ) or (
        str(a[i + 1])[-1] == "3"
        and str(a[i])[-1] != "3"
        and (a[i] ** 2 + a[i + 1] ** 2) >= mu**2
    ):
        cnt += 1
        if a[i] ** 2 + a[i + 1] ** 2 > mx:
            mx = a[i] ** 2 + a[i + 1] ** 2
print(cnt, mx)  # 180 190360573

Ответ: 180 190360573

Автор - rubygem17

Объяснение

None

Назад