EGEsoll - сборник решений задач из ЕГЭ

Задача 2

В файле содержится последовательность целых чисел. Элементы последовательности могут принимать целые значения от −10000 до 10000 включительно. Определите и запишите в ответе сначала количество пар элементов последовательности, в которых хотя бы одно число делится на 3, затем максимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента последовательности. Например, для последовательности из пяти элементов: 6; 2; 9; –3; 6 — ответ 411.

Download File 1

Добавлено: 29.03.26 11:59

Перейти к решению

Решение

Приведем решение на Python:

f = open("embed.txt")

a = [int(line) for line in f.readlines()]
f.close()

k = 0
ms = 0
for i in range(len(a) - 1):
    if a[i] % 3 == 0 or a[i + 1] % 3 == 0:
        k += 1
        s = a[i] + a[i + 1]
        if s > ms:
            ms = s
print(k, ms)  # 2802 1990

Ответ: 2802 1990

Автор - rubygem17

Объяснение

None

Назад