EGEsoll - сборник решений задач из ЕГЭ

Задача 1

В файле содержится последовательность из 10000 натуральных чисел. Каждое число не превышает 10000. Определите и запишите в ответе сначала количество пар элементов последовательности, у которых различные остатки от деления на d = 160 и хотя бы одно из чисел делится на p = 7, затем максимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два различных элемента последовательности. Порядок элементов в паре не важен.

Пример входных данных:

168

7

320

328

Пример выходных данных для приведённого выше примера входных данных:

4488

Пояснение. Из 4 чисел можно составить 6 пар. В данном случае условиям удовлетворяют пары: 168 и 320, 168 и 7, 320 и 7, 328 и 7. Максимальную сумму дает пара 168 и 320 — 488.

Download File 1

Добавлено: 22.03.26 14:15

Перейти к решению

Решение

Приведём решение на Python:

f = open("embed.txt")

a = []
for line in f.readlines():
    a.append(int(line))

k = 0
ms = 0
for i in range(len(a)):
    for j in range(i + 1, len(a)):
        if (a[i] % 160 != a[j] % 160) and ((a[i] % 7 == 0) or a[j] % 7 == 0):
            k += 1
            if a[i] + a[j] > ms:
                ms = a[i] + a[j]

print(k, ms)  # 12749665 19989

f.close()

Ответ: 12749665 19989

Автор - rubygem17

Объяснение

None

Назад