EGEsoll - сборник решений задач из ЕГЭ

Задача 9

Алгоритм вычисления значения функции F(n), где n  — целое неотрицательное число, задан следующими соотношениями:

F(n)  =  0, при n ≤ 1;

F(n)  =  F(n − 1) + 3n2, если n > 1 и при этом нечётно;

F(n)  =  n / 2 + F(n − 1) + 2, если n > 1 и при этом чётно.

Чему равно значение функции F(49)? В ответе запишите только целое число.

Добавлено: 17.05.26 09:13

Перейти к решению

Решение

Решение на Python:

def F(n):
    if n <= 1:
        return 0
    if n > 1 and n % 2 != 0:
        return F(n-1) + 3*n**2
    if n > 1 and n % 2 == 0:
        return n / 2 + F(n-1) + 2
print(F(49)) # 62820.0

Ответ: 62820

Автор - rubygem17

Объяснение

None

Назад