EGEsoll - сборник решений задач из ЕГЭ

Задача 7

Алгоритм вычисления значения функции F(n), где n  — целое неотрицательное число, задан следующими соотношениями:

F(0)  =  0;

F(n)  =  F(n / 2), если n > 0 и при этом n чётно;

F(n)  =  1 + F(n − 1), если n нечётно.

Назовите минимальное значение n, для которого F(n)  =  12.

Добавлено: 08.05.26 13:13

Перейти к решению

Решение

Решение на Python:

def f(n):
    if n == 0:
        return 0
    if n > 0 and n % 2 == 0:
        return f(n // 2)
    if n % 2 != 0:
        return 1 + f(n-1)

i = 0
while f(i) != 12:
    i += 1
print(i) # 4095

Ответ: 4095

Автор - rubygem17

Объяснение

None

Назад