EGEsoll - сборник решений задач из ЕГЭ

Задача 6

Алгоритм вычисления значения функции F(n), где n — натуральное число, задан следующими соотношениями:

F(1) = 1;

F(2) = 3;

F(n) = F(n−1) * F(n−2) + (n−2) при n > 2.

Чему равно значение функции F(5)? В ответе запишите только натуральное число.

Добавлено: 24.04.26 18:52

Перейти к решению

Решение

Решение на Python:

def f(n):
    if n == 1:
        return 1
    if n == 2:
        return 3
    if n > 2:
        return f(n - 1) * f(n - 2) + (n - 2)

print(f(5))  # 59

Ответ: 59

Автор - rubygem17

Объяснение

None

Назад