EGEsoll - сборник решений задач из ЕГЭ

Задача 5 досрок

Алгоритм вычисления значения функции F(n), где n - целое число, задан следующими соотношениями:

- F(n) = 3 при n меньше 10

- F(n) = (n + 4) * F(n-5), если n больше или равно 10

Чему равно значение выражения (F(257487)/683 + 67 * F(257477)) / F(257472)

Досрочный вариант 2026 - КЕГЭ

Добавлено: 17.04.26 21:08

Перейти к решению

Решение

Решение на Python:

from sys import setrecursionlimit

setrecursionlimit(200000000)


def f(n):
    if n < 10:
        return 3
    return (n + 4) * f(n - 5)


if __name__ == "__main__":
    print((f(257487) // 683 + 67 * f(257477)) // f(257472))  # 24994270044009

Ответ: 24994270044009

Автор - rubygem17

Объяснение

None

Назад