EGEsoll - сборник решений задач из ЕГЭ

Задача 4

Алгоритм вычисления значения функции F(n) и G(n), где n — натуральное число, задан следующими соотношениями:

F(1) = 0;

F(n) = F(n – 1) + n при n > 1;

G(1) = 1;

G(n) = G(n – 1) * n при n > 1.

Чему равно значение функции F(5) + G(5)? В ответе запишите только натуральное число.

Добавлено: 10.04.26 19:30

Перейти к решению

Решение

Ответ: 134

Решение на Python:

def f(n):
    if n == 1 or n <= 0:
        return 0
    return f(n - 1) + n

def g(n):
    if n == 1 or n <= 0:
        return 1
    return g(n - 1) * n

print(f(5) + g(5)) # 134

Автор - rubygem17

Объяснение

None

Назад