EGEsoll - сборник решений задач из ЕГЭ

Задача 3

Алгоритм вычисления значения функции F(n), где n — целое неотрицательное число, задан следующими соотношениями:

- F(0) = 0;

- F(n) = F(n / 2), если n > 0 и при этом чётно;

- F(n) = 1+F(n − 1), если n нечётно.

Добавлено: 05.04.26 15:18

Перейти к решению

Решение

Решение на Python:

def f(n):
    if n == 0:
        return 0
    if n % 2 == 0 and n > 0:
        return f(n / 2)
    if n % 2 == 1:
        return 1 + f(n - 1)


cnt = 0
for x in range(1, 1001):
    if f(x) == 3:
        cnt += 1
print(cnt)  # 120

Ответ: 120

Автор - rubygem17

Объяснение

None

Назад