EGEsoll - сборник решений задач из ЕГЭ

Задача 2

Алгоритм вычисления значения функции F(n), где n — натуральное число, задан следующими соотношениями:

- F(1) = 1;

- F(n) = F(n–1) * n при n > 1.

Чему равно значение функции F(5)? В ответе запишите только натуральное число.

Добавлено: 29.03.26 11:59

Перейти к решению

Решение

Данную задачу можно решить аналитикой. Поскольку заданные отношения описывают работу факториала от числа, то ответом является:

5! = 120

Решение на Python:

def F(n):
  if n == 1:
    return 1
  return f(n-1) * n

print(F(5)) # 120

Ответ: 120

Автор - rubygem17

Объяснение

None

Назад