EGEsoll - сборник решений задач из ЕГЭ

Задача 1

Алгоритм вычисления значения функции F(n), где n — натуральное число, задан следующими соотношениями:

- F(n) = 1 при n = 1;

- F(n) = n * F(n - 1), если n > 1.

Чему равно значение выражения F(2023) / F(2020)?

Добавлено: 29.03.26 11:59

Перейти к решению

Решение

Приведём решение на Python:

from sys import setrecursionlimit


def F(n):
    if n == 1:
        return 1
    elif n > 1:
        return n * F(n - 1)


setrecursionlimit(100000)
print(F(2023) / F(2020))

Отметим, что для приведённого решения необходимо увеличить лимит рекурсии.

Ответ: 8266912626

Автор - rubygem17

Объяснение

None

Назад