EGEsoll - сборник решений задач из ЕГЭ

Задача 9

Для какого наибольшего целого неотрицательного числа A выражение

(x > A) ∨ (y > x) ∨ (2y + x < 110)

тождественно истинно, то есть принимает значение 1 при любых целых неотрицательных x и y?

Добавлено: 17.05.26 09:13

Перейти к решению

Решение

Решение на Python:

r = 0
for A in range(1000):
    bad = False
    for x in range(1000):
        for y in range(1000):
            if not ((x > A) or (y > x) or (2*y + x < 110)):
                bad = True
                break
        if bad:
            break
    if not bad:
        r = A
print(r) # 36

Ответ: 36

Автор - rubygem17

Объяснение

None

Назад