EGEsoll - сборник решений задач из ЕГЭ

Задача 8

Для какого наибольшего целого числа А формула

((x ≤ 9) →(x ⋅ x ≤ A)) ⋀ ((y ⋅ y ≤ A) → (y ≤ 9))

тождественно истинна, то есть принимает значение 1 при любых целых неотрицательных x и y?

Добавлено: 10.05.26 17:00

Перейти к решению

Решение

Решение на Python:

for a in range(10000):
    bad = False
    for x in range(100):
        for y in range(100):
            if not (((x <= 9) <= (x * x <= a)) and ((y*y<=a) <= (y <= 9))):
                bad = True
                break
        if bad:
            break
    if not bad:
        print(a) # 99

Ответ: 99

Автор - rubygem17

Объяснение

None

Назад