EGEsoll - сборник решений задач из ЕГЭ

Задача 7

Для какого наименьшего целого неотрицательного числа A выражение

(x \* y < A) ∨ (x < y) ∨ (x ≥ 12)

тождественно истинно, то есть принимает значение 1 при любых целых неотрицательных x и y?

Для какого наименьшего целого неотрицательного числа A выражение

(x \* y < A) ∨ (x < y) ∨ (x ≥ 12)

тождественно истинно, то есть принимает значение 1 при любых целых неотрицательных x и y?

Добавлено: 08.05.26 13:13

Перейти к решению

Решение

Решение на Python:

for A in range(1000):
    bad = False
    for x in range(1000):
        for y in range(1000):
            if (x * y < A) or (x < y) or (x >= 12):
                ...
            else:
                bad = True
                break
        if bad:
            break
    if not bad:
        print(A) # 122
        break

Ответ: 122

Автор - rubygem17

Объяснение

None

Назад