EGEsoll - сборник решений задач из ЕГЭ

Задача 6

Для какого наименьшего целого неотрицательного числа А выражение

(y + 2x < A) ∨ (x > 30) ∨ (y > 20)

тождественно истинно, то есть принимает значение 1 при любых целых неотрицательных x и y?

Добавлено: 24.04.26 18:52

Перейти к решению

Решение

Решение на Python:

for A in range(100):
    f = False
    for x in range(100):
        for y in range(100):
            if not ((y + 2 * x < A) or (x > 30) or (y > 20)):
                f = True
                break
        if f:
            break
    if not f:
        print(A)  # 81
        break

Ответ: 81

Автор - rubygem17

Объяснение

None

Назад