EGEsoll - сборник решений задач из ЕГЭ

Задача 3

Сколько существует целых значений числа A, при которых формула

((x < 6) → (x**2 < A)) ∧ ((y**2 ≤ A) → (y ≤ 6))

тождественно истинна при любых целых неотрицательных x и y?

Добавлено: 05.04.26 15:18

Перейти к решению

Решение

Решение на Python:

res = []
for A in range(-100, 100):
    f = True
    for x in range(0, 100):
        for y in range(0, 100):
            if not (((x >= 6) or (x**2 < A)) and ((y**2 > A) or (y <= 6))):
                f = False

    if f:
        res.append(A)
print(len(res)) # 23

Ответ: 23

Автор - rubygem17

Объяснение

None

Назад