EGEsoll - сборник решений задач из ЕГЭ

Задача 2

Для какого наименьшего целого неотрицательного числа A выражение

(3x + 4y ≠ 70) ∨ (A > x) ∨ (A > y)

тождественно истинно при любых целых неотрицательных x и y?

Добавлено: 29.03.26 11:59

Перейти к решению

Решение

Приведём решение на Python:

for A in range(0, 100):
  f = False
  for x in range(0, 100):
    for y in range(0, 100):
      if not ((3 * x + 4 * y != 70) or (A > x) or (A > y)):
        f = True
        break
    if f:
      break
  if not f:
    print(A) # 11
    break

Ответ: 11

Автор - rubygem17

Объяснение

None

Назад