EGEsoll - сборник решений задач из ЕГЭ

Задача 9

Значение арифметического выражения 125 + 25**3 + 5**9 записали в системе счисления с основанием 5. Сколько значащих нулей содержит эта запись?

Добавлено: 10.05.26 17:00

Перейти к решению

Решение

Решение на Python:

def to_5(n):
    ost = []
    while n:
        ost.append(n%5)
        n //= 5
    return ost[::-1]

print(str(to_5(125+25**3+5**9)).lstrip("0").count("0")) # 7

Ответ: 7

Автор - rubygem17

Объяснение

None

Назад