EGEsoll - сборник решений задач из ЕГЭ

Задача 8

Значение выражения 125**5 + 25**9 − 30? записали в системе счисления с основанием 5.

Сколько цифр 4 содержится в этой записи?

Добавлено: 08.05.26 13:13

Перейти к решению

Решение

Решение на Python:

def to_5(n):
    ost = []
    while n:
        ost.append(n%5)
        n //= 5
    return ost[::-1]

print(to_5(125**5 + 25**9 - 30).count(4)) # 13

Ответ: 13

Автор - rubygem17

Объяснение

None

Назад