EGEsoll - сборник решений задач из ЕГЭ

Задача 7

Значение выражения 6 · 3435 + 5 · 497 − 50 записали в системе счисления с основанием 7. Сколько цифр 6 содержится в этой записи?

Добавлено: 24.04.26 18:52

Перейти к решению

Решение

Решение на Python:

def to_7(n):
    ost = []
    while n:
        ost.append(n % 7)
        n //= 7
    return ost[::-1]

print(to_7(6 * 343**5 + 5 * 49**7 - 50).count(6)) # 14

Ответ: 14

Автор - rubygem17

Объяснение

None

Назад