EGEsoll - сборник решений задач из ЕГЭ

Задача 4

Значение арифметического выражения 49**10 + 7**30 − 49 записали в системе счисления с основанием 7. Сколько цифр 6 содержится в этой записи?

Добавлено: 10.04.26 19:30

Перейти к решению

Решение

Ответ: 18

Решение на Python:

def to_7(n):
    ost = []
    while n:
        ost.append(n % 7)
        n //= 7
    return ost[::-1]

print(to_7(49**10 + 7**30 - 49).count(6)) # 18

Автор - rubygem17

Объяснение

None

Назад