EGEsoll - сборник решений задач из ЕГЭ

Задача 3

Значение арифметического выражения 9**8 + 3**5 − 9 записали в системе счисления с основанием 3. Сколько цифр 2 содержится в этой записи?

Добавлено: 05.04.26 15:18

Перейти к решению

Решение

Решение на Python:

def to_ter(n):
    ost = []
    while n:
        ost.append(n % 3)
        n //= 3
    return ost[::-1]
    
print(to_ter(9**8 + 3**5 - 9).count(2)) # 3

Ответ: 3

Автор - rubygem17

Объяснение

None

Назад