EGEsoll - сборник решений задач из ЕГЭ

Задача 2

Значение выражения 36**7 + 6**19 - 18 записали в системе счисления с основанием 6.

Сколько цифр 5 содержится в этой записи?

Добавлено: 29.03.26 11:59

Перейти к решению

Решение

Приведём решение на Python:

def to_6(n):
    ost = []
    while n:
        ost.append(n % 6)
        n //= 6
    return ost[::-1]

a = 36**7 + 6**19 - 18
print(to_6(a).count(5)) # 12

Ответ: 12

Автор - rubygem17

Объяснение

None

Назад