EGEsoll - сборник решений задач из ЕГЭ

Задача 10

Операнды арифметического выражения записаны в системах счисления с основаниями 9 и 11:

88x4y (9) + 7x44y (11).

(в скобках указана ССЧ)

В записи чисел переменными x и y обозначены допустимые в данных системах счисления неизвестные цифры. Определите значения x и y, при которых значение данного арифметического выражения будет наименьшим и кратно 61. Для найденных значений x и y вычислите частное от деления значения арифметического выражения на 61 и укажите его в ответе в десятичной системе счисления. Основание системы счисления в ответе указывать не нужно.

Добавлено: 17.05.26 09:13

Перейти к решению

Решение

Решение на Python:

for x in "012345678":
    for y in "012345678":
        a = int(f"88{x}4{y}", 9)
        b = int(f"7{x}44{y}", 11)
        if (a + b) % 61 == 0:
            print((a+b) / 61) # 2715

Ответ: 2715

Автор - rubygem17

Объяснение

None

Назад