EGEsoll - сборник решений задач из ЕГЭ

Задача 1

Значение выражения 2 * 216**6 + 3 * 36**9 - 432 записали в системе счисления с основанием 6. Сколько цифр 5 содержится в этой записи?

Добавлено: 22.03.26 14:15

Перейти к решению

Решение

Приведём решение на Python:

def to_6(n):
    ost = []
    while n:
        ost.append(n % 6)
        n //= 6
    return ost[::-1]


a = 2 * 216**6 + 3 * 36**9 - 432
print(to_6(a).count(5))

Ответ: 14

Автор - rubygem17

Объяснение

None

Назад